Customer Service Contact & Call Center Software connectivity issues

Incident Report for My Contact Center

Resolved

POP 6 Customers only:

Summary of issue
Some Customer Service Contact & Call Center Software users may have experienced connectivity issues within Customer Service Contact & Call Center Software applications, when placing or receiving calls, or when accessing reports through the Customer Service Contact & Call Center Software Admin Panel.

Business impact
None at this time.

Technical details
Our Engineering team identified an issue with the SIP load balancers and took mitigating actions to restore service. Full details will be provided in the RFO. If you continue to experience any issues, please contact our Support team for assistance.
Posted Jul 06, 2026 - 13:04 EDT

Update

POP 6 Customers only:

Summary of issue
Some Customer Service Contact & Call Center Software users may have experienced connectivity issues within Customer Service Contact & Call Center Software applications, when placing or receiving calls, or when accessing reports through the Customer Service Contact & Call Center Software Admin Panel.

Business impact
None at this time.

Technical details
Our Engineering team identified an issue with the SIP load balancers and took mitigating actions to restore service. Full details will be provided in the RFO. If you continue to experience any issues, please contact our Support team for assistance.
Posted Jul 06, 2026 - 13:03 EDT

Update

POP 6 Customers only:

Summary of issue
Some Customer Service Contact & Call Center Software users may continue to experience connectivity issues within Customer Service Contact & Call Center Software applications, during call establishment, or when accessing reports through the Customer Service Contact & Call Center Software Admin Panel.

Business impact
Some Customer Service Contact & Call Center Software users may experience connectivity issues within the Customer Service Contact & Call Center Software application, difficulties establishing calls, or errors when generating reports in the Customer Service Contact & Call Center Software Admin Panel.

Technical details
Our Operations team and additional technical teams remain actively engaged in resolving the issue affecting Customer Service Contact & Call Center Software applications and the Customer Service Contact & Call Center Software Admin Panel. Initial mitigation actions have been taken; however, some impact is still being observed. We are continuing to investigate and take additional steps toward full service restoration.

We will provide another update within 30 minutes or once new information becomes available.
Posted Jul 06, 2026 - 12:32 EDT

Investigating

POP 6 Customers only:

Summary of issue
Some Customer Service Contact & Call Center Software users may experience connectivity issues within Customer Service Contact & Call Center Software applications, during call establishment, or when accessing reports through the Contact Center Admin Panel.

Business impact
Some Customer Service Contact & Call Center Software users may experience connectivity issues within the Customer Service Contact & Call Center Software application, difficulties establishing calls, or errors when generating reports in the Contact Center Admin Panel.

Technical details
Our Operations team has identified the issue affecting Customer Service Contact & Call Center Software application and the Contact Center Admin Panel and has implemented changes to mitigate the impact. We are continuing to monitor the environment and actively investigate any remaining issues to ensure service is fully restored. We will provide another update within 30 minutes or once new information becomes available.
Posted Jul 06, 2026 - 12:02 EDT
This incident affected: High Availability Services (Queueing Services, Call Center Agent (CCA), Web Call Center Agent (WebCCA)).