Contact Center and voice services down for multiple datacenters

Incident Report for My Contact Center

Resolved

Summary of Issue:
Users may have experienced issues accessing Email, Contact Center, and Voice services due to a third-party provider disruption involving Cloudflare.

Business Impact:
None, all services and working as expected.

Technical Details:
Our Engineering teams confirmed the issue was related to a Cloudflare service disruption that impacted connectivity to certain Intermedia services. The third-party provider has restored service, and we have verified that Email, Contact Center, and Voice services are fully operational. If you continue to experience any issues, please contact our Support team for assistance.
Posted Feb 20, 2026 - 13:50 EST

Investigating

Summary of Issue:
We are currently investigating an issue affecting the Contact Center and Voice services in our Data Center.

Business Impact:
Some Contact Center users may be unable to log in or may experience issues handling inbound or outbound calls.

Technical Details:
Our Engineering teams are actively investigating and working to restore service as quickly as possible. We will provide an update within 30 minutes or sooner if additional information becomes available.
Posted Feb 20, 2026 - 13:36 EST
This incident affected: High Availability Services (Automatic Call Distribution (ACD), Queueing Services, Call Center Agent (CCA), Web Call Center Agent (WebCCA), Chat Services, Email Services, SIP).